summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Main.hs2
-rw-r--r--yi.cabal28
2 files changed, 13 insertions, 17 deletions
diff --git a/Main.hs b/Main.hs
index d6bcfff..6404bc5 100644
--- a/Main.hs
+++ b/Main.hs
@@ -86,7 +86,7 @@ main :: IO ()
main = do
mayClo <- execParser opts
case mayClo of
- Nothing -> putStrLn "Yi 0.15.0"
+ Nothing -> putStrLn "Yi 0.16.0"
Just clo -> do
let openFileActions = intersperse (EditorA newTabE) (map (YiA . openNewFile) (files clo))
moveLineAction = YiA $ withCurrentBuffer (lineMoveRel (fromMaybe 0 (startOnLine clo)))
diff --git a/yi.cabal b/yi.cabal
index a553df2..57320d9 100644
--- a/yi.cabal
+++ b/yi.cabal
@@ -1,9 +1,5 @@
--- This file has been generated from package.yaml by hpack version 0.17.1.
---
--- see: https://github.com/sol/hpack
-
name: yi
-version: 0.15.0
+version: 0.17.1
synopsis: Yi editor
category: Yi
homepage: https://github.com/yi-editor/yi#readme
@@ -23,7 +19,7 @@ flag emacs
default: True
flag pango
- description: Include the pango (GUI) frontend
+ description: Include the pango (GUI) frontend, this flag is ignored if compiling with ghc >= 8.2
manual: True
default: True
@@ -47,25 +43,25 @@ executable yi
, microlens-platform >= 0.3.4.0
, mtl >= 2.2.1
, optparse-applicative >= 0.13.0.0
- , yi-core >= 0.15.0
- , yi-misc-modes >= 0.15.0
- , yi-mode-haskell >= 0.15.0
- , yi-mode-javascript >= 0.15.0
- , yi-rope >= 0.7.0.1
+ , yi-core >= 0.17
+ , yi-misc-modes >= 0.17
+ , yi-mode-haskell >= 0.17
+ , yi-mode-javascript >= 0.17
+ , yi-rope >= 0.10
if flag(vty)
cpp-options: -DVTY
build-depends:
- yi-frontend-vty
- if flag(pango)
+ yi-frontend-vty >= 0.17
+ if flag(pango) && impl(ghc < 8.2)
cpp-options: -DPANGO
build-depends:
- yi-frontend-pango
+ yi-frontend-pango >= 0.17
if flag(vim)
cpp-options: -DVIM
build-depends:
- yi-keymap-vim
+ yi-keymap-vim >= 0.17
if flag(emacs)
cpp-options: -DEMACS
build-depends:
- yi-keymap-emacs
+ yi-keymap-emacs >= 0.17
default-language: Haskell2010