summaryrefslogtreecommitdiff
path: root/servant.cabal
diff options
context:
space:
mode:
authorMatthiasFischmann <>2020-07-31 18:29:00 (GMT)
committerhdiff <hdiff@hdiff.luite.com>2020-07-31 18:29:00 (GMT)
commit14b40630d4a7e0b8f1d201b33961a11d5b5ea974 (patch)
tree9bfad773da3672c77dd7bc8917b6734595ae3850 /servant.cabal
parent709a03143ca08256063d5d59dc524c6eefe41817 (diff)
version 0.18HEAD0.18master
Diffstat (limited to 'servant.cabal')
-rw-r--r--servant.cabal16
1 files changed, 9 insertions, 7 deletions
diff --git a/servant.cabal b/servant.cabal
index 05f9113..f5d821b 100644
--- a/servant.cabal
+++ b/servant.cabal
@@ -1,6 +1,6 @@
cabal-version: >=1.10
name: servant
-version: 0.17
+version: 0.18
synopsis: A family of combinators for defining webservices APIs
category: Servant, Web
@@ -25,7 +25,8 @@ tested-with:
|| ==8.2.2
|| ==8.4.4
|| ==8.6.5
- || ==8.8.2
+ || ==8.8.3
+ || ==8.10.1
, GHCJS == 8.4
extra-source-files:
@@ -55,6 +56,7 @@ library
Servant.API.RemoteHost
Servant.API.ReqBody
Servant.API.ResponseHeaders
+ Servant.API.Status
Servant.API.Stream
Servant.API.Sub
Servant.API.TypeLevel
@@ -79,7 +81,7 @@ library
--
-- note: mtl lower bound is so low because of GHC-7.8
build-depends:
- base >= 4.9 && < 4.14
+ base >= 4.9 && < 4.15
, bytestring >= 0.10.8.1 && < 0.11
, mtl >= 2.2.2 && < 2.3
, transformers >= 0.5.2.0 && < 0.6
@@ -96,7 +98,7 @@ library
-- Here can be exceptions if we really need features from the newer versions.
build-depends:
base-compat >= 0.10.5 && < 0.12
- , aeson >= 1.4.1.0 && < 1.5
+ , aeson >= 1.4.1.0 && < 1.6
, attoparsec >= 0.13.2.2 && < 0.14
, bifunctors >= 5.5.3 && < 5.6
, case-insensitive >= 1.2.0.11 && < 1.3
@@ -105,7 +107,7 @@ library
, http-types >= 0.12.2 && < 0.13
, mmorph >= 1.1.2 && < 1.2
, network-uri >= 2.6.1.0 && < 2.7
- , QuickCheck >= 2.12.6.1 && < 2.14
+ , QuickCheck >= 2.12.6.1 && < 2.15
, string-conversions >= 0.4.0.1 && < 0.5
, tagged >= 0.8.6 && < 0.9
, vault >= 0.3.1.2 && < 0.4
@@ -157,10 +159,10 @@ test-suite spec
, text
, transformers
- -- Additonal dependencies
+ -- Additional dependencies
build-depends:
hspec >= 2.6.0 && < 2.8
- , QuickCheck >= 2.12.6.1 && < 2.14
+ , QuickCheck >= 2.12.6.1 && < 2.15
, quickcheck-instances >= 0.3.19 && < 0.4
build-tool-depends: