summaryrefslogtreecommitdiff
path: root/servant-client.cabal
diff options
context:
space:
mode:
Diffstat (limited to 'servant-client.cabal')
-rw-r--r--servant-client.cabal17
1 files changed, 9 insertions, 8 deletions
diff --git a/servant-client.cabal b/servant-client.cabal
index bdbecc0..bd5fb45 100644
--- a/servant-client.cabal
+++ b/servant-client.cabal
@@ -1,6 +1,6 @@
cabal-version: >=1.10
name: servant-client
-version: 0.17
+version: 0.18
synopsis: Automatic derivation of querying functions for servant
category: Servant, Web
@@ -25,7 +25,8 @@ tested-with:
|| ==8.2.2
|| ==8.4.4
|| ==8.6.5
- || ==8.8.2
+ || ==8.8.3
+ || ==8.10.1
extra-source-files:
CHANGELOG.md
@@ -45,7 +46,7 @@ library
-- Bundled with GHC: Lower bound to not force re-installs
-- text and mtl are bundled starting with GHC-8.4
build-depends:
- base >= 4.9 && < 4.14
+ base >= 4.9 && < 4.15
, bytestring >= 0.10.8.1 && < 0.11
, containers >= 0.5.7.1 && < 0.7
, deepseq >= 1.4.2.0 && < 1.5
@@ -62,8 +63,8 @@ library
-- Servant dependencies.
-- Strict dependency on `servant-client-core` as we re-export things.
build-depends:
- servant == 0.17.*
- , servant-client-core >= 0.17 && <0.17.1
+ servant == 0.18.*
+ , servant-client-core >= 0.18 && <0.18.1
-- Other dependencies: Lower bound around what is in the latest Stackage LTS.
-- Here can be exceptions if we really need features from the newer versions.
@@ -120,15 +121,15 @@ test-suite spec
, wai
, warp
- -- Additonal dependencies
+ -- Additional dependencies
build-depends:
entropy >= 0.4.1.3 && < 0.5
, hspec >= 2.6.0 && < 2.8
, HUnit >= 1.6.0.0 && < 1.7
, network >= 2.8.0.0 && < 3.2
, QuickCheck >= 2.12.6.1 && < 2.14
- , servant == 0.17.*
- , servant-server == 0.17.*
+ , servant == 0.18.*
+ , servant-server == 0.18.*
, tdigest >= 0.2 && < 0.3
build-tool-depends: