summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOmariNorman <>2014-03-08 17:32:00 (GMT)
committerhdiff <hdiff@hdiff.luite.com>2014-03-08 17:32:00 (GMT)
commit165085b952128a085961f25e11e26f917fcb6d61 (patch)
tree6df66595010a4025c47ad54aa25578309898e73e
parent4cd6bdb1ba20ca426cc3062624b39c484f8aa633 (diff)
version 0.32.0.60.32.0.6
-rw-r--r--bin/penny-main.hs1
-rw-r--r--current-versions.txt10
-rw-r--r--lib/Penny/Wheat.hs5
-rw-r--r--minimum-versions.txt8
-rw-r--r--penny.cabal18
-rw-r--r--versions.m44
6 files changed, 25 insertions, 21 deletions
diff --git a/bin/penny-main.hs b/bin/penny-main.hs
index c0d5bd9..342b08e 100644
--- a/bin/penny-main.hs
+++ b/bin/penny-main.hs
@@ -1,6 +1,7 @@
module Main where
import Penny
+import Data.Monoid
import qualified Paths_penny as PPB
-- | This type contains settings for all the reports, as well as
diff --git a/current-versions.txt b/current-versions.txt
index affb703..2c399f9 100644
--- a/current-versions.txt
+++ b/current-versions.txt
@@ -1,7 +1,7 @@
This package was tested to work with these dependency
versions and compiler version.
These are the default versions fetched by cabal install.
-Tested as of: 2014-03-01 19:18:06.035563 UTC
+Tested as of: 2014-03-08 16:59:06.573315 UTC
Path to compiler: ghc-7.6.3
Compiler description: 7.6.3
@@ -32,7 +32,7 @@ Compiler description: 7.6.3
time-1.4.0.1
unix-2.6.0.1
-/home/massysett/penny/sunlight-31079/db:
+/home/massysett/penny/sunlight-15431/db:
MonadRandom-0.1.13
QuickCheck-2.6
action-permutations-0.0.0.0
@@ -52,10 +52,10 @@ Compiler description: 7.6.3
nats-0.1.2
ofx-0.4.0.2
parsec-3.1.5
- penny-0.32.0.4
+ penny-0.32.0.6
prednote-0.18.0.4
pretty-show-1.6.7
- rainbow-0.6.0.4
+ rainbow-0.12.0.0
random-1.0.1.1
random-shuffle-0.0.4
semigroupoids-4.0
@@ -63,7 +63,7 @@ Compiler description: 7.6.3
split-0.2.2
tagged-0.7
terminfo-0.4.0.0
- text-1.1.0.0
+ text-1.1.0.1
transformers-0.3.0.0
transformers-base-0.4.1
transformers-compat-0.1.1.1
diff --git a/lib/Penny/Wheat.hs b/lib/Penny/Wheat.hs
index 4f33239..4dd2f47 100644
--- a/lib/Penny/Wheat.hs
+++ b/lib/Penny/Wheat.hs
@@ -166,7 +166,10 @@ main
main ver getWc = do
rt <- S.runtime
(conf, args) <- parseArgs ver (getWc rt)
- term <- Rb.smartTermFromEnv (colorToFile conf) IO.stdout
+ term <-
+ if colorToFile conf
+ then Rb.termFromEnv
+ else Rb.smartTermFromEnv IO.stdout
items <- Cop.open args
let pstgs = getItems items
formatter = formatQty conf items
diff --git a/minimum-versions.txt b/minimum-versions.txt
index ff12424..d62673d 100644
--- a/minimum-versions.txt
+++ b/minimum-versions.txt
@@ -1,7 +1,7 @@
This package was tested to work with these dependency
versions and compiler version.
These are the minimum versions given in the .cabal file.
-Tested as of: 2014-03-01 19:18:06.035563 UTC
+Tested as of: 2014-03-08 16:59:06.573315 UTC
Path to compiler: ghc-7.4.1
Compiler description: 7.4.1
@@ -33,7 +33,7 @@ Compiler description: 7.4.1
time-1.4
unix-2.5.1.0
-/home/massysett/penny/sunlight-31079/db:
+/home/massysett/penny/sunlight-15431/db:
MonadRandom-0.1.13
QuickCheck-2.5
action-permutations-0.0.0.0
@@ -49,10 +49,10 @@ Compiler description: 7.4.1
nats-0.1.2
ofx-0.4.0.2
parsec-3.1.3
- penny-0.32.0.4
+ penny-0.32.0.6
prednote-0.18.0.4
pretty-show-1.5
- rainbow-0.6.0.4
+ rainbow-0.12.0.0
random-1.0.0.0
random-shuffle-0.0.4
semigroupoids-3.1
diff --git a/penny.cabal b/penny.cabal
index 03969ee..6913dea 100644
--- a/penny.cabal
+++ b/penny.cabal
@@ -3,7 +3,7 @@
-- penny.cabal for you.
Name: penny
-Version: 0.32.0.4
+Version: 0.32.0.6
Cabal-version: >=1.8
Build-Type: Simple
License: BSD3
@@ -69,7 +69,7 @@ Library
, multiarg >= 0.24.0.4 && < 0.25.0.0
, ofx >= 0.4.0.2
, prednote >= 0.18.0.4 && < 0.19.0.0
- , rainbow >= 0.6.0.4
+ , rainbow >= 0.12.0.0
-- Other packages
-- Package Version
@@ -183,7 +183,7 @@ Test-Suite penny-test
-- http://stackoverflow.com/questions/6711151
build-depends:
- penny == 0.32.0.4
+ penny == 0.32.0.6
, base >= 4.5.0.0 && < 5
-- Packages I maintain
@@ -210,7 +210,7 @@ Executable penny-gibberish
if flag(build-gibberish)
build-depends:
- penny == 0.32.0.4
+ penny == 0.32.0.6
, base >= 4.5.0.0 && < 5
-- Packages I maintain
@@ -236,7 +236,7 @@ Flag build-gibberish
Executable penny
Build-depends:
- penny ==0.32.0.4
+ penny ==0.32.0.6
, base >= 4.5.0.0 && < 5
hs-source-dirs: bin
@@ -255,7 +255,7 @@ Flag build-penny
Executable penny-selloff
Build-depends:
- penny == 0.32.0.4
+ penny == 0.32.0.6
, base >= 4.5.0.0 && < 5
other-modules: Paths_penny
@@ -274,7 +274,7 @@ Flag build-selloff
Executable penny-diff
Build-depends:
- penny == 0.32.0.4
+ penny == 0.32.0.6
, base >= 4.5.0.0 && < 5
hs-source-dirs: bin
@@ -293,7 +293,7 @@ Flag build-diff
Executable penny-reprint
Build-depends:
- penny == 0.32.0.4
+ penny == 0.32.0.6
, base >= 4.5.0.0 && < 5
hs-source-dirs: bin
@@ -309,7 +309,7 @@ Flag build-reprint
Executable penny-reconcile
Build-depends:
- penny == 0.32.0.4
+ penny == 0.32.0.6
, base >= 4.5.0.0 && < 5
hs-source-dirs: bin
diff --git a/versions.m4 b/versions.m4
index 83dac4c..9a5bc64 100644
--- a/versions.m4
+++ b/versions.m4
@@ -1,7 +1,7 @@
divert(-1)
# Penny version
-define(`pv_penny', `0.32.0.4')
+define(`pv_penny', `0.32.0.6')
# Haskell Platform
define(`pv_base', `4.5.0.0')
@@ -25,7 +25,7 @@ define(`pv_multiarg_max', `0.25.0.0')
define(`pv_ofx', `0.4.0.2')
define(`pv_prednote', `0.18.0.4')
define(`pv_prednote_max', `0.19.0.0')
-define(`pv_rainbow', `0.6.0.4')
+define(`pv_rainbow', `0.12.0.0')
# Other packages
define(`pv_action_permutations', `0.0.0.0')