summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichaelSnoyman <>2015-07-21 01:26:00 (GMT)
committerhdiff <hdiff@hdiff.luite.com>2015-07-21 01:26:00 (GMT)
commit405d6074be4e54fe6847dada1ae73e99399e593b (patch)
tree34946d8e6efa9dddf540fd804513a9bde85223d4
parente81fff4e5148404aec6fc51817cd58ca5041faa4 (diff)
version 2.1.62.1.6
-rw-r--r--ChangeLog.md3
-rw-r--r--Network/HTTP/Conduit.hs2
-rw-r--r--README.md1
-rw-r--r--http-conduit.cabal4
4 files changed, 9 insertions, 1 deletions
diff --git a/ChangeLog.md b/ChangeLog.md
new file mode 100644
index 0000000..0d8b0d3
--- /dev/null
+++ b/ChangeLog.md
@@ -0,0 +1,3 @@
+## 2.1.6
+
+* Deprecate `withManager` and `withManagerSettings`
diff --git a/Network/HTTP/Conduit.hs b/Network/HTTP/Conduit.hs
index c8501b2..cda99ee 100644
--- a/Network/HTTP/Conduit.hs
+++ b/Network/HTTP/Conduit.hs
@@ -287,6 +287,7 @@ withManager :: (MonadIO m, MonadBaseControl IO m)
=> (Manager -> ResourceT m a)
-> m a
withManager = withManagerSettings conduitManagerSettings
+{-# DEPRECATED withManager "Please new newManager conduitManagerSettings" #-}
withManagerSettings :: (MonadIO m, MonadBaseControl IO m)
=> ManagerSettings
@@ -296,6 +297,7 @@ withManagerSettings set f = bracket
(liftIO $ newManager set)
(liftIO . closeManager)
(runResourceT . f)
+{-# DEPRECATED withManagerSettings "Please new newManager" #-}
setConnectionClose :: Request -> Request
setConnectionClose req = req{requestHeaders = ("Connection", "close") : requestHeaders req}
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..6b8ac14
--- /dev/null
+++ b/README.md
@@ -0,0 +1 @@
+Make HTTP requests using the conduit library for a streaming interface.
diff --git a/http-conduit.cabal b/http-conduit.cabal
index 02bdf18..32637b8 100644
--- a/http-conduit.cabal
+++ b/http-conduit.cabal
@@ -1,5 +1,5 @@
name: http-conduit
-version: 2.1.5.1
+version: 2.1.6
license: BSD3
license-file: LICENSE
author: Michael Snoyman <michael@snoyman.com>
@@ -20,6 +20,8 @@ extra-source-files: test/main.hs
, nyan.gif
, certificate.pem
, key.pem
+ , README.md
+ , ChangeLog.md
library
build-depends: base >= 4 && < 5