summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorinaki <>2017-07-31 12:43:00 (GMT)
committerhdiff <hdiff@hdiff.luite.com>2017-07-31 12:43:00 (GMT)
commit78cd64b0e8d3703999340a4423205b77219a1746 (patch)
treeb4ca0570fab562c35890b20f4860f9d92bbc20b3
parent86ec8f1ceeb9b534040a695c4f558b50532f9ead (diff)
version 2.0.142.0.14
-rw-r--r--README.md2
-rw-r--r--gi-gobject.cabal5
2 files changed, 5 insertions, 2 deletions
diff --git a/README.md b/README.md
index 3a65f50..7b1b272 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,6 @@
# Documentation
Autogenerated documentation for this package can be found at
-[https://hackage.haskell.org/package/gi-gobject-2.0.13/docs/GI-GObject.html](https://hackage.haskell.org/package/gi-gobject-2.0.13/docs/GI-GObject.html)
+[https://hackage.haskell.org/package/gi-gobject-2.0.14/docs/GI-GObject.html](https://hackage.haskell.org/package/gi-gobject-2.0.14/docs/GI-GObject.html)
For general documentation on using [haskell-gi](https://github.com/haskell-gi/haskell-gi) based bindings, see [the project page](https://github.com/haskell-gi/haskell-gi) or [the Wiki](https://github.com/haskell-gi/haskell-gi/wiki).
diff --git a/gi-gobject.cabal b/gi-gobject.cabal
index 093433b..871ac8a 100644
--- a/gi-gobject.cabal
+++ b/gi-gobject.cabal
@@ -1,5 +1,5 @@
name: gi-gobject
-version: 2.0.13
+version: 2.0.14
synopsis: GObject bindings
description: Bindings for GObject, autogenerated by haskell-gi.
homepage: https://github.com/haskell-gi/haskell-gi
@@ -27,9 +27,12 @@ library
default-extensions: NoImplicitPrelude, ScopedTypeVariables, CPP, OverloadedStrings, NegativeLiterals, ConstraintKinds, TypeFamilies, MultiParamTypeClasses, KindSignatures, FlexibleInstances, UndecidableInstances, DataKinds, FlexibleContexts
other-extensions: PatternSynonyms, ViewPatterns
ghc-options: -fno-warn-unused-imports -fno-warn-warnings-deprecations
+
if flag(enable-overloading)
cpp-options: -DENABLE_OVERLOADING
build-depends: haskell-gi-overloading == 1.0.*
+ else
+ build-depends: haskell-gi-overloading == 0.0
pkgconfig-depends: gobject-2.0
build-depends: base >= 4.7 && <5,