summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdamBergmark <>2018-06-13 11:58:00 (GMT)
committerhdiff <hdiff@hdiff.luite.com>2018-06-13 11:58:00 (GMT)
commita134f5daaba8515b97176022009c430a9bdee24f (patch)
tree1132eabfd0b4cb841b9dfa2af5a8eb4faf352172
parent6248cfe749b6c8ecbba1e0afdf83aa0ec4253510 (diff)
version 0.1.0.10.1.0.1
-rw-r--r--CHANGELOG.md4
-rw-r--r--README.md7
-rw-r--r--base-compat-migrate.cabal9
3 files changed, 16 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d9a0e9c..be4626c 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,9 @@
# Changelog for base-compat-migrate
+## 0.1.0.1
+
+* Upgrade to `base == 4.11.1.*`
+
## 0.1.0.0
* Initial release
diff --git a/README.md b/README.md
index 9043f8a..c874800 100644
--- a/README.md
+++ b/README.md
@@ -43,6 +43,13 @@ This library offers a different work flow:
Whenever you wish to support newer versions of `base` or `base-compat`
you can repeat these steps.
+### Common Issues with Solutions
+
+* If your package declares Paths modules it won't compile without
+ access to base. You can drop the Paths module until the affected
+ component builds, and then add it again along with the base
+ dependency.
+
## Dependencies
Since `base-compat-migrate` re-exports modules, we depend on minor
diff --git a/base-compat-migrate.cabal b/base-compat-migrate.cabal
index ed6480a..b82c17d 100644
--- a/base-compat-migrate.cabal
+++ b/base-compat-migrate.cabal
@@ -1,17 +1,18 @@
cabal-version: 1.21
name: base-compat-migrate
-version: 0.1.0.0
+version: 0.1.0.1
license: BSD3
license-file: LICENSE
copyright: (c) 2018 Adam Bergmark
maintainer: adam@bergmark.nl
author: Adam Bergmark
-tested-with: ghc ==8.4.1
+tested-with: ghc ==8.4.3
homepage: https://github.com/bergmark/base-compat-migrate#readme
bug-reports: https://github.com/bergmark/base-compat-migrate/issues
synopsis: Helps migrating projects to base-compat(-batteries).
description:
- Please see the included README or visit <https://github.com/bergmark/base-compat-migrate#readme>.
+ Temporarily replace your base & base-compat(-batteries) dependencies with base-compat-migrate to verify that you are using all available base-compat modules.
+ Please see the included README or visit <https://github.com/bergmark/base-compat-migrate#readme> for more information.
category: Development
build-type: Simple
extra-source-files:
@@ -236,7 +237,7 @@ library
Paths_base_compat_migrate
default-language: Haskell2010
build-depends:
- base ==4.11.0.*,
+ base ==4.11.1.*,
base-compat ==0.10.1.*
executable base-compat-migrate-generate